1
$\begingroup$

I am having trouble selecting faces vertices edges , sometimes i just cannot select at all, other times if i go through all objects in the hierarchy i stumble upon one face which gets selected. Select all sometimes works other times it doesn't, sometimes it's as if simply switching from Edit to Object mode affects the objects and i suddenly can select stuff. Not to mention that select all almost never works. I tried convert To mesh, Split by edge and then Separate by Loose Parts but there is nothing consistent sometimes i even have trouble deleting an object which is even more frustrating. Any ideas what is wrong with the geometry or maybe i am doing something wrong?

Oh and the texturing is a massive issue, i need to add a texture per face or at least 3 or 4 different materials but when i finally succed in adding a material or two like all sorts of faces start changing material and i cant find a way of removing a material from a face other than deleting the material from each individual face. ugh

enter image description here

Like right now i want to select all the walls and add to them a material but i can't even select the faces. Vast majority of vertices are missing.

enter image description here

enter image description here

PIcture of selected faces intended to have material and result with almost all faces getting the material -enter image description here

Material gets attached to all faces which i don't want to have the Material on.

enter image description here

$\endgroup$
  • $\begingroup$ Are you using an add-on to make that shape, or did you build it from scratch? Just curious, because the mesh seems to be comprised of multiple objects, and the fact that their names begin with "path", suggests they may be generated from a curve or something like that. $\endgroup$ – Christopher Bennett Jun 17 at 22:07
  • $\begingroup$ i got it from Inkscape the geometry is from an svg file. $\endgroup$ – mavish Jun 17 at 23:16
  • $\begingroup$ Yeah. I thought it might be something like that. You said you tried to convert to mesh. Did you use Mesh from curve? $\endgroup$ – Christopher Bennett Jun 17 at 23:19
  • $\begingroup$ yes Mesh from Curve. some details about it here blender.stackexchange.com/questions/182412/… $\endgroup$ – mavish Jun 17 at 23:20
  • $\begingroup$ Any chance you could post the .blend? It might be easier than me asking you a thousand questions. $\endgroup$ – Christopher Bennett Jun 17 at 23:21
1
$\begingroup$

Ok. I think I fixed it. What I did was delete the light (so I could select all and only get mesh parts). In object mode, I selected all, and right click > join to make it all one piece (one mesh). I tried the CTRL+J method a couple of times first, so you might have to fiddle with it - I don't know why it didn't work until I used the right click method. Anyway, once it was all joined into a mesh, I went to edit mode, then select all > mesh > clean up > merge by distance - because there are "seams" between the edge pieces. I counted 1160 vertices removed. After that, I had to UV unwrap again because there were overlaps, but I think it's good to go. If, in the future, you need it to be more pieces, you can always separate it later.

I'll upload a copy of the file I modified for reference.

Here it is -

Hope this helps.

EDIT - Here is your file "cleaned up" it still is not perfect - I did a quick and messy job on the UV unwrap just so I could get the textures to look decent - you may have to redo them. Also, many of the floors are still n-gons, this might not matter, but if you want to triangulate for a game engine later, you might want to make sure it's all quads first to be sure there a re no issues. I separated what "chunks" of floor looked appropriate, but obviousely, you will want to divide some of them on your own for texturing reasons - i'll leave that to you. I also have to remove your texture in order to pack the ones I used, you'll have to replace it.

Here is the (cleaned up) file. Hope this finally works for you.

| improve this answer | |
$\endgroup$
  • $\begingroup$ so i did an edge split and Loose for the faces selected in the pic added to main Question and then i added a material to those same faces and it added the material to All faces (including walls) except that left lower corner face. I think Blender is trying to humiliate me. It is succeeding. $\endgroup$ – mavish Jun 18 at 1:33
  • $\begingroup$ Yeah, that floor. Just select it, and in the materials section pick the "globe". Underneath the assign button there is another "globe". click that and a list should pop up with your other material in it. Pick the material from that list. $\endgroup$ – Christopher Bennett Jun 18 at 2:05
  • $\begingroup$ Alternatively, since it looks like you're using the same material for the whole thing at this point, you might just want to go back to object mode and start again. Select the materials, and hit the little minus next to them. This will remove these materials and their slots, you can then add a new slot and then a new material (the same one again) and apply it to all (if there's only one material slot, it will apply ti the whole mesh anyway) $\endgroup$ – Christopher Bennett Jun 18 at 2:08
  • $\begingroup$ i selected a few of the floors, created a new Slot, added a new material and instead of getting the material on those few floors it went on the exact opposite. Basically now i have Material on all faces except the ones i want. pic added to main Question $\endgroup$ – mavish Jun 18 at 2:15
  • $\begingroup$ Yeah, the problem is a topology issue at this point. You can see there are edges on the walls all over the place "terminate" at the floor (the edge loop stops there). I'm cleaning it up for you. I'll upload when I'm done. $\endgroup$ – Christopher Bennett Jun 18 at 2:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.