2
$\begingroup$

In this space animation that I'm working on, I would like to composite a blurry version of the planet into the background to create an atmosphere effect. So far I've added a cryptomatte node to cut out and blur the planet only and added an alpha over node to place the blurred planet on top of the black background. For some reason when I view the alpha over node, it also shows asteroids which are not included in the cryptomatte.

The first image shows the environment layer that is attached to the alpha over node.

The second image shows the blurred cryptomatte image that should be placed over the background.

The third image shows the output of the alpha over node which for some reason includes the asteroids.

Am I missing something or is this a bug? I've tried reopening the scene, and recreating the node setup. An alternative to the cryptomatte would be multiple render layers but for the sake of render time, I would prefer to not go that route. (Using 2.83)

Here is the blend file: io.blend

enter image description here enter image description here enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Cryptomatte can not generate clean alpha and emission combinations. Use a separate render pass. $\endgroup$ – troy_s Jun 17 '20 at 22:14
2
$\begingroup$

You need to Connect the matte output of the Crytomatte to the Alpha Over Node for it to work as shown in the image. It will get rid of the Asteroids.

Pls pack the textures if you are sending a blend file as the textures go missing as you can see the image.

enter image description here

EDIT

As mentioned in the Comments If you set it up like in the Image you can use Cryptomatte. Also I cleaned up the nodes a bit

enter image description here

$\endgroup$
3
  • $\begingroup$ Thanks for the reply! That definitely solves the asteroid problem, but it also cuts off the edges of the blur. I managed to solve the issue by using the Z combine node rather than alpha over. $\endgroup$ – Aaron zw Jun 18 '20 at 13:12
  • $\begingroup$ The way I implemented it. The crytomatte basically works as a mask. Since I was only focused of getting rid of the asteroids I didn't notice the blur. The mask is sharp by default. You can use dilate/erode node to smooth it out if you want and you should see the blur. $\endgroup$ – Tien Jun 18 '20 at 13:52
  • $\begingroup$ A handy way to check whether your nodes are working as intended is to ctrl+shift click on a node. It will preview the outputs of that node. You will have to enable Node Wrangler addon for this. Just putting it out there incase you don't know. $\endgroup$ – Tien Jun 18 '20 at 13:58
0
$\begingroup$

I ended up using the Z Combine node rather than the Alpha Over Node and it works great! I guess the alpha over node just ignores cryptomatte alpha data?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.