0
$\begingroup$

So, I manually created a navigation mesh (i.e. added and edited a plane mesh > changed the physics type in bge to navigation mesh). I then added a steering actuator (path following) to my human model, set-up the target object and used the navigation mesh I just created. But when I press P, the human model doesn't follow the path of the navigation mesh. What it does is walk through a path that doesn't have a navigation mesh.

Problem

What I want is to make the actor object (human model) to use the navigation mesh as the path like so, Object following the navigation mesh path

This is my logic set-up enter image description here

Also, the human model can't detect any obstacles along the way, but the is another problem.

Any help is appreciated. Thanks in advance.

Building the navigation mesh using the properties in the Scene also doesn't work

$\endgroup$
1
$\begingroup$

Instead of setting a "Navigation Mesh" physics type on an existing object, you should generate the navigation mesh via the relevant button in the scene properties.

In my tests, that seems to work fine.

Here's a tutorial for that procedure: https://www.youtube.com/watch?v=aMWeTXL98mM

And here's a working demo: nav_mesh.blend

$\endgroup$
  • $\begingroup$ I actually did that before moving on to setting the object to "Navigation Mesh" physics type because it did not achieve what I want to achieve with the path following. But then, setting the object to Navigation Mesh also did not work. $\endgroup$ – Rani O. Oct 28 '14 at 19:43
  • $\begingroup$ @RaniO. What exactly do you want to achieve? In my demo (now included in my answer above) the path following seems to work exactly as it should, and I used the technique outlined in the referenced tutorial. $\endgroup$ – Goran Milovanovic Oct 28 '14 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.