2
$\begingroup$

I have a pretty beefy PC: RTX 2070, I7-9700K but somehow my Eevee animation ends up taking more than 1 minute per frame yet can render at around 10-50 FPS in the viewport with minimal quality loss compared to the full render, at around the same resolution. So, are there render settings that I should change to make the animation render faster? or is the Eevee render just super broken?

It seems like this is a fairly common problem, brought up in many unsolved questions: Why are my Eevee renders much slower to output than they are in a viewport?

Will it soon be possible to render an Eevee animation in realtime (2.8 Beta)?

Eevee Preview Render from Python

Many have come to the conclusion that either the normal render does more calculations to make a more realistic image, or that it takes time to save the image to the disk.

If it is the first case, what settings can I change to make each render take the same time? I highly doubt it is the second case as it should not take more than a minute to save a 1mb file to my solid state drive.

And yes, I have tried the viewport render, which does speed things up substantially (like more than 50x faster than the regular render), but I'm still struggling to understand why the regular render is taking so long.

Here is a picture of one of the more demanding frames of the animation: enter image description here

$\endgroup$
5
  • $\begingroup$ How does your scene look like? What are your render settings? $\endgroup$ – brockmann Jun 16 '20 at 22:35
  • $\begingroup$ @brockmann 40 samples, the scene is fairly big with a lot of images and models $\endgroup$ – 10 Replies Jun 16 '20 at 22:58
  • 1
    $\begingroup$ can you attach a screenshot ? $\endgroup$ – Bruk Jun 20 '20 at 14:22
  • $\begingroup$ @Bruk added one $\endgroup$ – 10 Replies Jun 20 '20 at 21:55
  • $\begingroup$ If you want a quick and dirty solution without programming and that will probably work, You can F3 full screen your window then use Open Broadcaster Software (OBS) to record the frames as they play out, just hide your grid and mouse and crop and you're good. $\endgroup$ – 4nof Jun 21 '20 at 19:22
2
$\begingroup$

To reduce render time in EEVEE you can try the following steps:

  1. In the screen space reflections menu and turn off refraction and enable Half Res Trace.
  2. In the sampling menu reduce the samples for rendering.
  3. In the output properties panel reduce the resolution of the from a 100% to about 75% or lower.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.