0
$\begingroup$

I've been trying to scale a rigged character. I applied a new animation to it from Mixamo which works well, but I am unable to scale it. I've literally been trying to scale a character up for two hours but every time I do, it goes back to being small. I've done Ctrl + A > Apply Scale but then it just causes my character to roam around randomly in space. I'm selecting the armature for scaling. Does anyone know a workaround for this? I've also uploaded a video to demonstrate what is going wrong.

Please see the video here

$\endgroup$
2
  • $\begingroup$ it looks like we need to log in to see your video, maybe share your character (armature only) here: blend-exchange.giantcowfilms.com $\endgroup$
    – moonboots
    Jun 16, 2020 at 18:16
  • $\begingroup$ I've uploaded the video here and a zip containing the armature here $\endgroup$
    – Aman
    Jun 17, 2020 at 3:10

2 Answers 2

1
$\begingroup$

What happens is that, at frame 1, you've keyframed the armature Scale, with a value of 0.01.

If you apply the Scale it means that you assign your armature its current size as its 1/1/1 scale. But as it continues to play the action's scale keyframes, it's immediately going to be scaled down to 0.01 of this new scale.

So what you can do is either apply its Visual Transformation, or delete the XYZ scale keyframes in the Dope Sheet.

$\endgroup$
5
  • $\begingroup$ i tried this with my mixamo important character, applied to armature + character, filtered in dope sheet by scale, deleted all keyframes, but still the animation is wrecked. What can it be? $\endgroup$
    – Chris
    Jan 20 at 5:42
  • $\begingroup$ hello Chris, maybe share your file? $\endgroup$
    – moonboots
    Jan 20 at 7:59
  • $\begingroup$ i did on a new question ;) $\endgroup$
    – Chris
    Jan 20 at 8:28
  • $\begingroup$ does josh sanfelici he answer correctly? I haven't looked into your file yet... $\endgroup$
    – moonboots
    Jan 20 at 8:38
  • $\begingroup$ I hadn’t the time to check that out…but as I know him…I think yes, it should be right. Was running and have to calm down my heartbeat…🙈 $\endgroup$
    – Chris
    Jan 20 at 9:13
0
$\begingroup$

Found a solution. The bones probably had a scale component on them, so they reset each time you hit play. What I did was parent it to an empty then scale the empty instead.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.