1
$\begingroup$

I have a terrain surface and i extruded it downwards along the z axis. This resulted in the material being stretched at the side. How do I have the sides and bottom to not have any color at all? I realise I am using 'materials' and 'texture' interchangeably as I m unaware of the differences.

enter image description here

I have tried:

  1. UV editing > Unwrap > Project from view (bounds)
  2. Tweaking material properties, ensuring that it is on 'clip', 'linear', 'flat'

Been trying to solve this and other problems for many weeks now. Any help would be great thank you.

enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ select the faces you need to have a different material, create the material you want and assign it to the faces $\endgroup$ – susu Jun 16 '20 at 15:49
  • 1
    $\begingroup$ see this post: Add different materials to different parts of a mesh $\endgroup$ – susu Jun 16 '20 at 15:50
  • $\begingroup$ Regarding Material and Texture, maybe this can clear it up texture-vs-material-vs-shader $\endgroup$ – Xylvier Jun 16 '20 at 17:19
  • $\begingroup$ Thank you very much. I have progressed alot since! $\endgroup$ – Leonard Ng Jul 5 '20 at 7:53
0
$\begingroup$

Create a new material for the edges and sides of the object.

With the object selected, go into edit mode. Select all the face that you want to change the color of. Now in the material properties tab, you will see an "Assign" option. With the correct material selected, press assign.

$\endgroup$
1
  • $\begingroup$ Thank you very much. The instructions were very clear. $\endgroup$ – Leonard Ng Jul 5 '20 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.