I've created this Scene In blender 2.82 and gave it a test render with 350 Samples, but the quality was very low. Now I tried it with 600 Samples, but it didn't get better. What am I doing wrong?

Test-Render 600 Samples

Info: I'm using blender 2.82 with cycles on my CPU. I set the render samples to 600, set the Light bounces to 6 and used the basic built-in denoiser.


  • 2
    $\begingroup$ That's a stunning scene! By low quality, are you referring to the camera resolution? Given that the image's resolution you provided is 563x373, I'm guessing you should increase the resolution instead of samples. $\endgroup$ Commented Jun 16, 2020 at 14:50
  • $\begingroup$ And i'd say, a few hundred samples isn't what i'd call "high quality settings". Unless you're making some particular scene rendeted as a static image where the lighting and surroundins happen to need only a few hundred samples to render well. But usually it's not enough. $\endgroup$
    – Lauloque
    Commented Jun 17, 2020 at 11:19
  • $\begingroup$ subtle reflections/refractions can increase in detail to up to 10 000 samples as far as I know. $\endgroup$
    – Yvain
    Commented Jul 14, 2022 at 16:14
  • $\begingroup$ If blurriness is an issue, you might try checking your camera settings to make sure Depth of Field is not enabled by accident. And if you are sending the render result through compositing nodes (such as Scale), bypass them to see if the image becomes more crisp. From the images you provided, I don't believe your render is getting up-scaled, but I mention it anyway as general advice. $\endgroup$
    – Mentalist
    Commented Mar 14, 2023 at 3:23

1 Answer 1


As I commented, I believe you need to increase the render resolution instead of the scene samples/light bounces. See this if you are unsure how.

rendering - How to scale the cameras view bounds? - Blender Stack Exchange


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .