0
$\begingroup$

odd transparency behavior

odd normal issue maybe

I've been trying to resolve this issue all morning and I'm sure it's something small. I looked into the material but that seems fine...I reset the material to make sure. My normals are facing the right direction.... At some point i hit all the options under Mesh>normals and "smooth vectors" did do something but still looks wrong.

Looks like this in EEVEE and the viewport. Cycles looks fine but i'm trying to use eevee

It might have to do with object properties? Anyways any help would be greatly appreciated so i can move on with this small project.

Also the building mesh came from using "image as planes" and then extruding out the sides.

$\endgroup$
5
  • $\begingroup$ Have you tried to recalculate the normals to the outside of the model? $\endgroup$
    – Hendriks3D
    Commented Jun 14, 2020 at 21:27
  • $\begingroup$ Make sure that the normals point in the right direction and try to set the Blend Mode for Eevee to Alpha Hashed. $\endgroup$ Commented Jun 14, 2020 at 21:39
  • $\begingroup$ Can you upload a copy of your .blend file? It looks like smooth shading + smooth vectors, and I can't tell from your photo but maybe front-face culling? Not likely, but it would be worth a closer look. $\endgroup$ Commented Jun 14, 2020 at 21:45
  • $\begingroup$ "Blend Mode for Eevee to Alpha Hashed" THAT WORKED, thanks @robert. looks like the addon "images as planes" has it set to a different settings when you create a mesh from it. Shoot I knew it was something small, If only i could have my morning back...Also how do you make it so this post has the solution in green or is that done by a moderator. anyways thanks! $\endgroup$ Commented Jun 14, 2020 at 21:51
  • $\begingroup$ @ChristopherBennett Yea I stumbled upon shade flat and that made the mesh look better. thanks for replying so quick $\endgroup$ Commented Jun 14, 2020 at 21:53

1 Answer 1

3
$\begingroup$

You're experiencing a sorting problem due to Alpha Blend. Changing the Blend Mode to Alpha Hashed in the material properties should fix this issue. If you have to use Alpha Blend make sure that Show Backside is disabled.

Sorting Problem

When writing to the color buffer using transparent blend modes, the order in which the color blending happens is important as it can change the final output color. As of now Eevee does not support per-fragment (pixel) sorting or per-triangle sorting. Only per-object sorting is available and is automatically done on all transparent surfaces based on object origin.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .