5
$\begingroup$

im new to Blender (Blender Internal). Hope anyone can help, i'm hurry cuz of a deadline!.

With a plane with a normal map aplied to it and it's material set to Shadow Only I'm triying to create an alpha bg video with particle with shadows projections over it (a dead body actually) to integrate later on AE.

The issue: shadows are not bending influenced by the normal map of the plane. (see red plane)

Solutions or performance improvements are very welcome!

Shadows not influenced by normal map yet

$\endgroup$
7
  • $\begingroup$ Are you using ray traced shadows? $\endgroup$ – someonewithpc Oct 25 '14 at 20:28
  • $\begingroup$ on Render-> Shading-> ray tracing is activated. That's the way to turn them on? $\endgroup$ – Fallouturama Oct 25 '14 at 20:44
  • $\begingroup$ On a lamp's properties enable ray shadow. $\endgroup$ – someonewithpc Oct 25 '14 at 20:56
  • $\begingroup$ it's enabled already :/ $\endgroup$ – Fallouturama Oct 25 '14 at 21:00
  • 2
    $\begingroup$ Could you use a displacement instead? $\endgroup$ – someonewithpc Oct 25 '14 at 21:02
6
$\begingroup$

A normal map on a plane will fake the shading, but will not deform shadows projected on the plane.

enter image description here

Essentially the shadows are those of the underlaying plane.

enter image description here

To create real displacement: add a displacement modifier using a texture. (Note you might need to subdivide your object and create more vertices to displace.)

enter image description here enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Beautifully explained!, the same @someonewithpc finally suggested. Thnx! $\endgroup$ – Fallouturama Oct 25 '14 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.