1
$\begingroup$

When I opened the render window, it was empty even though the camera was pointing at the object and all the objects were set to be visible in viewport and in render

Thinking a restart would help, I restarted blender and now blender does not even show the objects in the viewport

Picture of screen

The file is uploaded here : blend file

Thanks in advance for the help!

$\endgroup$
2
  • $\begingroup$ This seems problematic indeed. Any chance you had these objects as part of multiple collections, and then removed a collection? I don't have a definitive solution, but I found 2 discussions related here - developer.blender.org/T66086 and here - blender.stackexchange.com/questions/143691/…. I couldn't restore the stuff from orphaned in your file using this method, but then again, I don't know where things are supposed to go. Hopefully, the stuff you need wasn't orphaned and then purged from memory when you restarted. $\endgroup$ – Christopher Bennett Jun 9 '20 at 5:21
  • $\begingroup$ Thanks Christopher, I don't quite understand your explanation, but it seems that moving battle axe in character collection breaks everything. It could be due to godot game tools. Also, it seems that only moving battleaxe causes it to break, while moving the other pieces don't. Below is a link where moving the battleaxe will break everything: drive.google.com/file/d/16zXGdw2lZ103NAqY_CRcQd9WCEVIrDAD/… $\endgroup$ – Philip Wee Jun 9 '20 at 5:44
0
$\begingroup$

The scale of the armature is too small. Also the rotation was modified. enter image description here
Select the armature in Outliner. Then press , . Also clear the location If you need. enter image description here

$\endgroup$
2
  • $\begingroup$ Hi tetii, unfortunately, this does not solve the main issue. Once any attempt to render the image is made, it is invisible (ie it is at the pre-broken state). Any idea how to fix that? $\endgroup$ – Philip Wee Jun 13 '20 at 2:40
  • $\begingroup$ Oh, I can't help you because I can't reproduce the issue. Objects are still displayed after animation rendering trough Blender 2.83. $\endgroup$ – tetii Jun 13 '20 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.