0
$\begingroup$

For some reason my origin's rotation got terribly messed up. I have been trying to fix it by aligning the origin to a face or a vertex but it only gets worse. I need to make an array and for that reason clean up the origin's rotation. Because as it is right now I don't get a regular and even offset.

I would be grateful for any input because I am out of ideas on how to fix it.

Thank you in advance!

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Did you try CONTROL+A to apply transformations? $\endgroup$ – Sanbaldo Jun 8 at 15:20
  • $\begingroup$ Yes, tried that. But the local always returns to a slightly tilted rotation. $\endgroup$ – SPAC5R Jun 8 at 15:37
  • 1
    $\begingroup$ can you share the blend file to check? $\endgroup$ – Sanbaldo Jun 8 at 15:43
1
$\begingroup$

It's 'easier' than it used to be, here's one way, using the 'View' Transform Orientation.

  1. Find a reference rectangular face, preferably facing down your intended Z, select it in Edit Mode, and set the Transform Orientation to 'View'
  2. Orthographic: ShiftNumpad 7 align your view to the face.
  3. ShiftS > Cursor to Selected .. now the cursor should be centred on the face.
  4. In Object Mode, with the Header > Options set to 'Origins', move the origin: ShiftS > Selected to Cursor
  5. Header > Object > Transform menu.. Align to Transform Orientation. Now the Origin shoould be aligned with the view, and the face.

There may be some 90 degree swivels to do while in the view, to get your X,Y and Z on the right axes, and don't forget to switch the 'Origins' option off.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thank you very much! Sorry for the late comment, missed the notification! :) $\endgroup$ – SPAC5R Jul 1 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.