I am following the BlenderGuru tutorial of making a cup of coffee, but when I make the coffee liquid using volume absorption, the coffee only appears to absorb light from the top. When I adjust the view to the sideview, it still looks transparent.

Anyone know what I do wrong? Please see the image with nodes attached. CoffeeShaderPage

  • $\begingroup$ I checked out the video you mentioned. I can't listen, because I can't find my headphones, but around the 11:20 mark he discusses re-calculating normals. Have you done that step? I think recalculating-outside should fix your problem. $\endgroup$ Jun 8, 2020 at 6:11
  • $\begingroup$ Hi Chris, thx for the reply. I have selected all the vertices, and done the recalculation of normals. it looks all blue in the "face orientation" view. But still, the volume absorption only applied to the top! $\endgroup$ Jun 8, 2020 at 6:55

1 Answer 1


I am new to Blender, so I can't say I solve this problem (I am quite sure if the coffee cup is animated, the coffee liquid won't looks right) , but I do discover what causes this problem.

When the scene setting is like the follow (the camera looking at the perpendicular to the light source), the side of the coffee mesh looks transparents. enter image description here

I changed the scene setting like the below (the camera facing the light source) enter image description here

Now the volume absorption works! the side of the coffee is now brown instead of transparent.

I am guessing this is due to how volume absorption works. If there is no light passing through the mesh to your camera (i.e. camera perpendicular to the light source), the volume absorption calculate that there is no light absorbed at all, meaning transparent. (but in real world, it should appeared darker, or something else, but not transparent).

Hope this makes sense, if you guys happens to know how to make it more realistic, please tell me. thanks!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .