0
$\begingroup$

I've just started using Blender particle system and rigid body stuff. I've tried to emit particles from the volume of the mesh but they just sit on the surface of the mesh no matter what I try to do.

I want all the particles to be inside the mesh from the beginning and not on the surface. Is this possible?

I was following this tutorial - https://www.youtube.com/watch?v=1gM8yEMFMjg The particle system with random distribution The particle system with random distribution Here is the system with jittered distribution Here is the system with jittered distribution

Emit from Verts and faces yield similar results with some particles escaping the mesh in the first frame itself.

Here is the blend file if I wasn't able to explain it properly: https://drive.google.com/file/d/1eRWzE-IprJ0dP3l_zxkEso5sTgC0Vbq7/view?usp=sharing

Any help would be appreciated!

$\endgroup$
1
  • 1
    $\begingroup$ You probably need to flip the normals to get the volume filled with particles. $\endgroup$
    – affronaut
    Nov 11, 2020 at 17:42

2 Answers 2

0
$\begingroup$

The end frame for your simulation is the same as your start frame. That means that your particle simulation will run for one frame (in which it will emit the particles), and then stop playing.

Simply change it from 1 to the desired number of frames you want your simulation to run for (if you don't know what this is, then just set this to the number of total frames your project is set to render, which I can see is 250).

Frame end pointing image

Simply put, set the Frame End to 250 in the Particle System Properties tab.

$\endgroup$
1
  • $\begingroup$ The particle setting that i put was so that all the particles are emitted in the first frame and the lifetime is for 50 frames(after which they will disappear). I want my scene to have the mesh full of the spheres from the beginning, hence the frame end is at 1. The problem I'm facing is to place all the particles inside the mesh and not on the surface or outside. Hope I clarified myself! $\endgroup$
    – Praneeth
    Jun 8, 2020 at 9:39
0
$\begingroup$

Problem: I'm not sure Could be solidify modifier


Fix to make it emit particles from the volume.

Press ctrl + c on the object

Open another window (don't close)

remove everything

Press ctrl + v in another file

Remove all modifiers and particle system

Remake particle system

Copy iy back in the other file.

$\endgroup$
2
  • $\begingroup$ I've tried what you suggested but it still behaves the same way. However, I did get around the problem by using another object to emit the particles inside the first mesh. $\endgroup$
    – Praneeth
    Jun 8, 2020 at 9:58
  • $\begingroup$ @Praneeth Try taking off the solidify modifier. $\endgroup$
    – Yohello 1
    Jun 8, 2020 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.