0
$\begingroup$

I am attempting to add a hat to an animated character. The correct procedure outlined in the answer here:

Parenting an object to a bone not working

"The correct procedure to parent the empty to the bone is:

Select the empty

Shift select the armature

Go to pose mode

Select the bone you need as parent

Press Ctrl P and choose "bone" option."

This does not work. Note attached video.

I have tried to parent via "bone relative", I tried the hip (master) bone. I tried to parent to the head (which is not the correct process). Nothing is working - I'm stumped.

You can see from the video that in rest mode the hat is correctly parented. Could it be that I was attempting to attach it rest mode rather than pose mode? That's a bit harder....what is the correct process?

Parenting to Bone not Working

$\endgroup$
2
  • $\begingroup$ ...an additional issue is that I cannot clear the parent of the hat. I wanted to try parenting in pose mode...but it will not let me clear the parent....crazy difficult...sigh. $\endgroup$ – DrIgnatiusCole Jun 7 '20 at 13:43
  • $\begingroup$ That INDEED was the problem - I had tried to parent in REST mode not POSE mode. $\endgroup$ – DrIgnatiusCole Jun 7 '20 at 13:50
0
$\begingroup$

The answer to the problem is that I was trying to parent the object in REST mode. In order for this to work it has to be POSE mode.

If anyone wants to contribute an understanding of what REST mode is even for, that would be helpful for anyone getting to grips with this problem.

$\endgroup$
0
$\begingroup$

Rest mode is when you do Alt + S, G, or R.

It's the pose that the rig goes to when you reset it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.