0
$\begingroup$

I've been trying to render out a simple fire/smoke sim. Everything looks fine in viewport but when rendered the flames do not show. I'm using cycles with optix in blender 2.83 steam release, on windows 10.

Viewport viewport render preview

render output

material setup

I have tried changing shader setups just to see the same thing, that the flame and temperature volume info seems to look fine in viewport, but be abscent from render, changing number of light bounces, and volumes step rates and max steps.

$\endgroup$
  • $\begingroup$ This seems more of an issue between smoke VP and render settings, not shading. Try to match them and see if it's still different. $\endgroup$ – Frederik Steinmetz Jun 7 at 7:24
1
$\begingroup$

I found the solution, turns out my particle emitter was disabled in render, which disabled rendering fire.

This is weird because smoke is still rendered and volume passes are all black, and disabling the emitter in viewport does not affect anything.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.