3
$\begingroup$

I am having a very strange problem when I bake an Ambient Occlusion!

The problem is very very visible, When I click Bake, it bakes everything and then in the last few seconds it does this weird "vortex" kind of effect. It always starts from the bottom left.

Also, any UV unwrapping doesn't work either (UV unwrap, Smart uv project etc. all don't work).

enter image description here

$\endgroup$

closed as off-topic by gandalf3, iKlsR Oct 25 '14 at 7:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question appears to be off-topic because it is a bug report and not an actual question. These should be reported to Blender's tracker instead." – gandalf3, iKlsR
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ That seems like a bug... $\endgroup$ – someonewithpc Oct 24 '14 at 10:46
  • $\begingroup$ Is it possible you could upload your .blend? It looks to me like you have overlapping UVs, which can cause this kind of "z-fighting" $\endgroup$ – gandalf3 Oct 24 '14 at 19:29
  • $\begingroup$ pasteall.org/blend/32335 password : lmg $\endgroup$ – Knuckles209cp Oct 24 '14 at 20:30
  • $\begingroup$ Actually it's not a bug. The baking takes the wire material into account. In the baking options you should tick 'Normalized' (then materials are ignored for the baking), this fixes the problem. $\endgroup$ – jasperge Oct 30 '14 at 18:20
3
$\begingroup$

For some reason this seems to be caused by the wire material.

If you remove it by pressing the - button:

enter image description here

Then it works as expected:

enter image description here

This looks like a bug to me. You might want to consider reporting it to the tracker. I've since reported it here.


Also note that there are some internal faces and non-manifold geometry in your model, which can also result in some artifacts. Try pressing ⎈ Ctrl⎇ Alt⇧ ShiftM in edit mode to select problem spots.

$\endgroup$
  • 1
    $\begingroup$ As I said in the comment to the question and in the bug tracker, you can actually just tick 'Normalized' in the bake options. This way materials are ignored when baking and it bakes just fine with a wire material. $\endgroup$ – jasperge Oct 30 '14 at 18:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.