1
$\begingroup$

I have installed Blender 2.83 in my arch Linux installation and it crashes. I downloaded it from the repo then also tried from the official site. It still fails.. help needed

# Blender 2.83.0, Commit date: 2020-06-03 14:38, Hash 211b6c29f771

# backtrace
blender(BLI_system_backtrace+0x34) [0x55806be25ba4]
blender(+0xd03e7d) [0x558069b6ee7d]
/usr/lib/libc.so.6(+0x3c3e0) [0x7fa86daaa3e0]
blender(GPU_draw_list_command_add+0x57) [0x55806bcf68f7]
blender(+0x10b9355) [0x558069f24355]
blender(+0x10bac94) [0x558069f25c94]
blender(+0x10e5916) [0x558069f50916]
blender(+0x10b22f3) [0x558069f1d2f3]
blender(DRW_draw_render_loop_ex+0x2c7) [0x558069f1d5f7]
blender(view3d_main_region_draw+0x98) [0x55806a5d3dd8]
blender(ED_region_do_draw+0x8a1) [0x55806a1a1e61]
blender(wm_draw_update+0x4d5) [0x558069e30a75]
blender(WM_main+0x34) [0x558069e2ea34]
blender(main+0x36b) [0x558069b3d31b]
/usr/lib/libc.so.6(__libc_start_main+0xf2) [0x7fa86da95002]
blender(_start+0x2e) [0x558069b6b0fe]

Note: My arch installation is also new.

$\endgroup$
1
$\begingroup$

< My Problem >

Blender freezes whole UI of operating system.

< Solution >

I am not responsible if this damage your OS or any other thing

I have Intel UHD 630 GPU, I switched from Intel to MODESETTING driver, this fixed my issue, Try it IF it works for you , share with other people. :)

*To enable MODESETTING you have to edit /etc/mkinitcpio.conf
Put MODULES=(... i915 ...) below MODULES="" *Delete this package from system xf86-video-intel. *Then reboot system.

< About System >

CPU: Intel core i5-8400 Ram: 8gb Gpu : Intel UHD 630 Os: EndeavourOS

< How to revert these changes? >

*Install this package system xf86-video-intel. *You have to edit /etc/mkinitcpio.conf
remove MODULES=(... i915 ...) below MODULES=""

< Reference > https://wiki.archlinux.org/index.php/Kernel_mode_setting#Early_KMS_start

| improve this answer | |
$\endgroup$
  • $\begingroup$ Don't post solutions that may damage users' OS or hardware. That's the best way to avoid trouble later. $\endgroup$ – Lukasz-40sth Aug 4 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.