0
$\begingroup$

I have two grease pencil objects: one at origin and the other at Y: 92m (far back from the camera.) I'm trying to get the background to be blurred using the camera. (I know I can blur the object itself but in another scene I'm going to be moving the camera in between objects.) I'm using the Eevee render engine and I am in the Rendered viewport setting, but depth of field is not working. I have the camera focused on the character in front with an F-stop of 3.6.

enter image description here

I added some spheres to test if DOF was working at all, and it does work for the spheres. (In eevee) enter image description here

(In cycles with F-stop of 0.5) enter image description here

Am I missing something?

$\endgroup$
1
$\begingroup$

Unfortunately Grease Pencil doesn't have true camera DOF enabled yet, but there are several workarounds available:

1) Add the "blur" effect under the "visual effects properties" tab and check "Use Depth of Field". The grease pencil object will then blur with camera movement(but it only blurs the GP object as a whole instead of parts of the GP object as in true DOF)

2) Convert the grease pencil object to geometry, which will then react properly to camera DOF: https://www.youtube.com/watch?v=Fl8PXZWnxr4

3) All grease pencil objects come with a depth map. Use the "Defocus" Node and "lens distortion" node in the compositor. You can download an example file of the node setup here: https://www.local-guru.net/blog/2019/7/13/grease-pencil-experiment-4---depth-of-field

It's likely that true camera DOF will be enabled in a future version of Blender, but for now these workarounds may provide the result you are looking for.

Hope that helps!

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you! I'll look into these. $\endgroup$ – user-is-here Jun 6 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.