1
$\begingroup$

Greetings: I'm new to Blender. I've done my due diligence by reviewing about 100 posts on similar rendering questions but, within the limitations of my understanding, I've not found a response that appears to answer my question.

In attempting to render an animation using eevee, I am unable to get the rendered images to show the glossy finish that I get in the Modeling editor when I select the Render Preview button. Instead, I get the grey appearance shown in the eevee image.

Any help would be appreciated. Thanks for your time.

Image rendered in eevee.

Image previewed in camera view in Modeling workspace.

enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

You need an HDRI texture for the proper reflections you are looking for. Go into the shading tab and switch from object shading to world shading (highlighted below). Add an environment texture, and assign an HDRI texture

(If you need HDRI images, one place that has a good selection of free ones is here - https://hdrihaven.com/hdris/).

Alternatively, if you want the same ones that come with blender (used in lookdev), they are in the folder ../2.82/datafiles/studiolights/world. I think the one you used in the preview is forest.exr

Connect it up as shown below and enjoy.

enter image description here

For the other problem you are having, your (base) material node setup should look like this. Either add the nodes if they're not there, or if you want to just start again, hit the minus button next to the material, and add a new one.

NODE SETUP

EDIT: A SAMPLE PROJECT FOR YOU

Ok, I made a .blend project that SHOULD be pretty much the same as what you're working with. It works fine for me. Download it, and have a look, and see if it

a) it works for you, and

b) has any differences between it's settings and yours.

File is here -

| improve this answer | |
$\endgroup$
  • $\begingroup$ Christopher: I followed your instructions above, after downloading a HDRI and installing it. The node arrangement looks exactly like yours with World selected in the drop down menu in the node editor while in Shader. The background now shows the HDRI image, however the objects in the scene are purple, and the rendered image has not changed from the image I posted above. It shows no background, and the text is still grey instead of shiny. $\endgroup$ – Rocket Surgeon Jun 5 at 1:30
  • $\begingroup$ They are purple. I have a screen shot, but cannot figure out how to post it in response to your posts. $\endgroup$ – Rocket Surgeon Jun 5 at 1:36
  • $\begingroup$ Ahh, ok. I edited my original post, and added the new image. Hope that's ok. $\endgroup$ – Rocket Surgeon Jun 5 at 1:40
  • $\begingroup$ I probably have something incorrectly set in my material or texture. Sucks being a wanker newbie. $\endgroup$ – Rocket Surgeon Jun 5 at 1:41
  • $\begingroup$ I'm new to nodes, and Blender in general. However, when in the Shading editor, and selecting Object from the drop down menu, with the text selected and highlighted, I have no node elements showing. $\endgroup$ – Rocket Surgeon Jun 5 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.