0
$\begingroup$

I am trying to make a video by combining three different sources. The main source has a monologue and runs in the background. At certain times, the other videos pop up on the screen. I need to sync the mouth movements in the small clips with the background video.

  1. The two overlays have no audio. The audio tracks were deleted.
  2. The two overlays have transforms (offset and crop) applied.
  3. The two overlays are applied as Alpha Over blends.

Everything shows up just fine when rendered, but it has proven incredibly difficult to lip-sync...so I am trying to use proxies.

Proxies are generated and the base video works fine, but neither of the composite strips appear in the preview.

I have tried turning on all options I could find: prefetch, cache composite, cache raw, strip cache, per strip, per project - and have not found a combination that allows me to see the overlays with the background video.

I even tried swapping one of the overlays onto the first video channel (2 - channel 1 is the background clip's audio), but then nothing appeared in the preview.

Oh, and when looking in the file system, the proxy files for each video is present.

Even if I have to hide the background clip, I can lip sync just using the over videos and background audio.

Using Blender 2.82.

$\endgroup$
1
$\begingroup$

In the original approach, Offset and Crop were applied to the strip. This approach did not work.

However, it does work when Offset and Crop are applied to a transform. Click on the strip, then in the menu, choose Add -> Effect Strip -> Transform. This then creates a green transform block for the strip (in the next channel). By applying the Offset and Crop to the transform and then regenerate the proxies, everything worked as expected.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.