0
$\begingroup$

I've been trying to use blender (2.80 - from Ubuntu repositories) for 2d animation. The 2d animation screen I'm presented with guides me towards using the grease pencil for drawing. But now to the problem.

My grease pencil stroke appears to be about half-opacity and I can't find where that gets set. I've found I can change both the stroke and fill properties in the "Materials" pane. When I set them both to solid black, then the fill will appear black as expected, but the stroke will appear grey both in the viewport and in the render output. If I change the color to 100% red, it will appear unsaturated red.

I did find that if I change the world background color to blue and the stroke to red (in materials), then the stroke color will appear purple. And having multiple strokes intersect will increase the opacity. So I'm pretty convinced there is some default opacity (effectively anyway) for strokes (but not fills) somewhere that I haven't found. I suspect it's probably somehow due to the "lines" layer being different from "fills" layer, but I can't find any differences!

I've never really used blender, but I have tried do mess around with it in the past - maybe I changed some ancient setting years ago to make this happen?

I went through all the options I could find on all the default panes in the 2d-animation workspace and disabled any custom colors (or set them to black) and set all the opacities for everything to be 100% (IDK what onion skinning is, or what the viewport display controls) and none of that seemed to work. I searched Google for variations of "blender grease pencil stroke opacity" and only found more complicated issues (eg: a bug from a few years ago with grease pen on top of 3d geometry) - not instructions about this apparently basic behavior. Even in the documentation seems to just talk about how you just set the color to what you want - but not so for me!

$\endgroup$
0
$\begingroup$

Ugh. So I had been messing with this for an hour. But after posting, I tried to do it from scratch and discovered the "strength" slider.

So the solution is - at the top of the screen, move the "strength" slider from the default 0.6 to 1.0. And you've got full-opacity lines!

| improve this answer | |
$\endgroup$
  • $\begingroup$ and for future reference, if you want to change the strength of an already drawn stroke, you can do that in sculpt mode (???) $\endgroup$ – wilks Aug 5 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.