1
$\begingroup$

I've got the following Octant Cube and would like to make the planes slightly transparent so that I can see what's behind them.

Blender Octant

I've gone to Plane > Plane > Color Blue > material section of the Navigation Bar. There, as you can see in the previous image, there's a Surface: Background with a specific color.

Tried in a brute force way changing the Surface to different values other than background and shifting its properties to see if in at least one could get that slight transparency but no success yet.

How to make a simple plane slightly transparent to see the other planes behind?


As per Frederik Steinmetz's suggestion, I've created a new material called Transparent and assigned but can't see any difference.

Alpha material


As per Emir's feedback, I've gone to View > Area > Select Vertical Split. On the new new Viewport, went to Editor Type and selected Shader editor. Inside the Shader Editor Press Shift + A then S and Type "Transparent BSDF". Shift + A Then S again and now type Mix Shader. ConnectED the Transparent Node to the mixer and also connected the Principled BSDF, making sure alpha has 0.750. Connected that Mix Shader Node to de output.

Still not working

Just did gone through the same process again and still didn't get anything transparent

No transparent plane


In order to see if the problem was due to me joining the planes before, created them again and follow the procedure mentioned by Emir but still no success in making it transparent.

Joining wasn't necessarily the problem

$\endgroup$
  • 1
    $\begingroup$ I don't really dare to post this as an answer, because I feel like I missed something: Click on the use nodes btn, You'll get a bunch of options (principled shader), one of which is Alpha. That's opacity in percent. $\endgroup$ – Frederik Steinmetz Jun 2 at 19:59
  • $\begingroup$ @FrederikSteinmetz when I click in Use Nodes, it only shows - base color, metalic, specular, roughness $\endgroup$ – Tiago Martins Peres 李大仁 Jun 2 at 20:43
1
$\begingroup$

One option is to use Transparent Node

-Go to View > Area > Select vertical or Horizontal Split.

-On this new Viewport go to Editor Type and select Shader editor.

-Inside the Shader Editor Press Shift + A then S and Type "Transparent".

-Shift + A Then S again and now type Mix Shader.

-Connect your Transparent Node to this mixer and also connect the Principled BSDF.

-Connect that Mix Shader Node to de output.

** Under the transparent Node Color White is 100% transparent and Black is 0% Transparent.

enter image description here

If up to this point you don't get transparent plane, go to Material Properties > Settings > Blend Mode and change that property to Alpha Blend.

| improve this answer | |
$\endgroup$
  • $\begingroup$ The GIF and the explanation look great, learn many new things. Still, as I shared in the new Question edit, didn't manage to get it with some transparency... $\endgroup$ – Tiago Martins Peres 李大仁 Jun 2 at 22:39
  • $\begingroup$ From your image i'm noticing that your Transparent Node is Black, that means 0 Transparent, you need to change the color to White. This node is not related whit the Alpha input $\endgroup$ – Emir Jun 3 at 4:26
  • $\begingroup$ Emir I tested different variations of that as you mention («** Under the transparent Node Color White is 100% transparent and Black is 0% Transparent.»). Could it be that I joined the planes? (blender.stackexchange.com/a/178471/84701) $\endgroup$ – Tiago Martins Peres 李大仁 Jun 3 at 6:47
  • 1
    $\begingroup$ Here you have it... mega.nz/file/… $\endgroup$ – Emir Jun 4 at 19:40
  • 1
    $\begingroup$ @Emir found what was missing and already made an edit to include that info. Thank you for your time! $\endgroup$ – Tiago Martins Peres 李大仁 Jun 5 at 21:33
1
$\begingroup$

Just to be on the safe side: Create a new material, assign it to one of your planes. in the Shader editor you get:
enter image description here

Adjust the alpha to your likings.
You should be able to see the same options in the material properties, when you clicked use nodes. You need to be in rendered view to preview any transparency effects. Make sure to check 'use nodes'.
[Big EDIT]
If you want to see the effect in preview: enter image description here This way you can't set the transparency per object, just for all. You will soon be able to use these settings for individual objects in solid view:
enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Just updated the question with my attempt. Nothing changed. Could it be that it's because I joined all the planes? $\endgroup$ – Tiago Martins Peres 李大仁 Jun 2 at 21:06
  • $\begingroup$ You need to be in rendered view to see that $\endgroup$ – Frederik Steinmetz Jun 2 at 21:23
  • $\begingroup$ Updated the image, the problem remains $\endgroup$ – Tiago Martins Peres 李大仁 Jun 2 at 21:33
  • $\begingroup$ My Viewport shading doesn't have the options yours has... Only get Lighting (Selection box with Scene Lights or Scene World) and Render Pass (dropdown with Combined) $\endgroup$ – Tiago Martins Peres 李大仁 Jun 4 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.