0
$\begingroup$

I have sculpted and retopologized a dragon model. When I try to bake a normal map using details from my high poly model I am getting artefacts on my normal map. I get much better results using a cage, but there are still some problems in areas such as the mouth, wings, and under the legs:Inside Mouth Artefacts

Wing Artefacts

Artefacts Under The Legs

There are also similar artefacts under the horns and on other parts of the wings. The mouth artefacts can be cleared up by not using a cage and putting the ray distance under 0.4, but then I get worse problems on other portions of my mesh such as the upper legs. I have tried using 32bit float and 8k for my normal maps. Changing the placement of my seams multiple times did not make much difference. I played around with the extrusion option when using a cage, but no extrusion gives better results. I could go into gimp (or photoshop), and try to fix the problems manually, but I would like to know why I am getting them. Here are the bake settings that work best for me (to make the cage I took the low poly version went into edit mode then used ALT-S to scale up until the cage covered the high-poly version):

enter image description here

Here is my .blend, but without the high-poly model because it took up too much space:

EDIT: I re-created my cage, manually scaling certain areas more than others then re-baked with the new cage. The normal map looks better in the mouth area, but the normal map applied to the dragon still looks just as bad in the viewport.

$\endgroup$
0
$\begingroup$

In order to get rid of the artefacts on the wings and the feet I had to make my low poly mesh (more) similar to my high poly mesh in the areas that had normal baking problems. For the artefacts in the mouth, under the legs, and under the horns I had to adjust my cage manually to make sure there was no overlap. Sometimes the normal map did not display properly; changing the color space on my image texture "refreshed" the node making the normal map display properly. The normal map has come out fine, and I have not changed any of my bake settings except putting the Margin to 32px instead of the default 16px.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.