1
$\begingroup$

I'm very new to Blender and I'm having an issue in using invert select.

First, I selected these vertices:

enter image description here

Then, I used Select> Invert:

enter image description here

But instead of selecting only those vertices that were not selected, everything was selected:

enter image description here

How can I fix this?

$\endgroup$
3
  • $\begingroup$ Unfortunately, invert selection has some strange results, and always seems to wortk best for me using faces only. For this - I would select the whole loop of vertices, and de-select every other using "checker deselect". If you need the opposite vertices selected after that, change the offset by 1. $\endgroup$ Jun 2 '20 at 13:28
  • $\begingroup$ It may just look as if all the vertices are not selected .. have look at the selected vertex count in the information strip under the main window: 'x / y vertices' .. check that x = y. $\endgroup$ Jun 2 '20 at 17:24
  • $\begingroup$ @ChristopherBennett, I cannot replicate any issues. This may be a hardware or driver glitch that may be fixed by some settings in the Preferences or driver update or something or maybe it's a bug for some reason effecting only some users or another issue in the specific model. I don't think this is a universal experience for everyone. Invert selection works for me on 2 different PCs flawlessly all the time for a very long time with many different Blender versions. I have never had any issues with it working with Blender 8 hours a day... $\endgroup$ Jun 2 '20 at 22:08
1
$\begingroup$

You might have double vertices. What might have happened is that the vertices that were selected were double ones, so inverting the selection also selected the vertices that were being overlapped by them. This would give the illusion that all vertices are selected.

To remove double vertices, in Edit Mode go to Mesh > Clean Up > Merge By Distance. Any detected double vertices will be removed and a message will show up saying how many double vertices were detected and removed. If no double vertices were removed. this might be a bug.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.