2
$\begingroup$

I started a discussion here, but no working answers: Blender Freezes

I downloaded blender-2.72-linux-glibc211-x86_64 from blender.org/download for Ubuntu. I extracted using the default archive extractor that ships with Ubuntu.

My hardware is, Intel i7, 8 Gig Ram, Graphics Intel Haswell Mobile, OS Type 64 bit.

I am using Nouveau display driver from x-org server. However, additional drivers indicate I have some nvidia drivers available to switch. Switching to any of them still makes blender crash.

Drivers in additional settings

I am not even able to kill the blender process when it freezes. The only way to stop it from running is logging out or restarting. Using kill processes from terminal or System monitor doesn't kill blender.

All applications run normal, except Blender which freezes totally, and Google Chrome which freezes for some 4 minutes after starting it, but it comes back to normal and I'm able to use.

Blender never recovers itself from the crash. Plus, I even tried running blender from terminal, to see if I'll be able to learn what happens, but I never get anything after the app crashes, and no logs as to what happens.

Any assistance will be much appreciated.

$\endgroup$

closed as off-topic by someonewithpc, Ray Mairlot, ideasman42 Oct 22 '14 at 21:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question appears to be off-topic because it is a bug report and not an actual question. These should be reported to Blender's tracker instead." – someonewithpc, Ray Mairlot, ideasman42
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ Does blender not even quit if you send SIGKILL? (run killall -s KILL blender from a terminal). Try using the proprietary drivers and see if they help. $\endgroup$ – gandalf3 Oct 22 '14 at 21:11
  • $\begingroup$ Yes, try using the proprietary drivers, I had this also on Ubuntu. $\endgroup$ – stacker Oct 23 '14 at 5:59
  • $\begingroup$ Nouveau drivers are known to crash, have observed this on multiple systems recently, for now best use proprietary drivers (or software OpenGL as last resort). $\endgroup$ – ideasman42 Oct 23 '14 at 8:28
  • $\begingroup$ I've tried installing the proprietary, but I wonder how to know its even working. Plus, Blender isn't able to recognize it even when its installed, so I doubt if its properly installed or what $\endgroup$ – KhoPhi Oct 24 '14 at 12:00
  • $\begingroup$ When I enable the proprietary drivers, I can't use Ubuntu continuously even for 5 minutes, as the whole desktop environment freezes. Ctrl + Alt + F1 takes me to tty and I'm able to respawn the lightdm, otherwise, restarting becomes my last option. I just don't know what's wrong and how to even start with. $\endgroup$ – KhoPhi Oct 26 '14 at 13:32

Browse other questions tagged or ask your own question.