0
$\begingroup$

I made a simple image in Inkscape to go into the background of the shot to make it look as though the robot was in space. However, when I go to add it through the materials tab, it shows up as pink whilst rendering. I looked into the problem and tried to troubleshoot on my own by using the File >>> External Data >>> Find Missing File and it still did not want to show up. I have attached the file extensions and the Blender UI while I am editing for anyone who needs it.

Thanks to anyone who can help. I am sure this is a simple fix that a beginner like me cannot figure out.

Blender UI

File Extension

Shader Nodes

$\endgroup$
6
  • 1
    $\begingroup$ Can you post a pic of your node setup under the shading tab? $\endgroup$ – Christopher Bennett Jun 1 '20 at 23:35
  • $\begingroup$ @ChristopherBennett Done! Does that help any? $\endgroup$ – DCoolMan Jun 2 '20 at 13:28
  • $\begingroup$ Interesting, I must say I don't think I have ever seen an empty "color space" box before. What happens if you click on it, can you select sRGB or linear or anything? $\endgroup$ – Christopher Bennett Jun 2 '20 at 13:36
  • $\begingroup$ @ChristopherBennett I changed it to all of the different drop down options and nothing changed... $\endgroup$ – DCoolMan Jun 2 '20 at 14:01
  • $\begingroup$ There has to be something wrong with the image then. Maybe try starting from scratch? Add a new image texture, select the file and connect it up - maybe it will help Blender "remember" the path to the image. $\endgroup$ – Christopher Bennett Jun 2 '20 at 14:08
1
$\begingroup$

Make sure the image is not corrupt before adding it into Blender. If this happens, re-download or re-export the image.

$\endgroup$
0
$\begingroup$

In the first image you posted go to the color space and set it to something. It is not supposed to be blank

$\endgroup$
1
  • $\begingroup$ I went through all of the options available on the drop down and none of them did anything to fix it... $\endgroup$ – DCoolMan Jun 2 '20 at 14:00
0
$\begingroup$

Try to do it the UV way, unrap it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.