0
$\begingroup$

I am new to Blender, but have worked with other 3D programs. I'm trying to rig a model in Blender 2.82 using the built-in human metarig and rigify. It's gone well so far, but I cannot weight the eye mesh to the eye bones. They simply will not move with it properly.

I have the armature modifier applied properly, as seen below... armature modifier screen

And the vertex groups named after the appropriate bones as I understand it after further research.

vertex group settings

The meshes are weighted 100% to the appropriate vertex groups. To my understanding this should work, but the eyes simply do not move properly. I've tried renaming the groups to other bones involved in eye movement, and tested them on their own with a different instance of this default rig, but can't get them to work.

The blend file can be found on this Blend-Exchange link, if it helps.

I'm stumped. Can anyone help with this issue?

Thank you.

$\endgroup$
0
$\begingroup$

You've disabled the bone's Deform option. Also don't forget to unlock its Transform options.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Worked like a charm, thank you! Odd that option would be turned off on generating the rig, but I appreciate knowing about it now. $\endgroup$ – Mole Jun 1 at 7:53
  • $\begingroup$ it is enabled by default, so you must have disabled it by accident. Edit: well, if it's an auto-generated rig it may be the default setting but I don't get why it would be. $\endgroup$ – moonboots Jun 1 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.