2
$\begingroup$

I am having an issue with Blender 2.80 on Ubuntu 19.10 Linux. If I attempt to import any GLTF files, Blender crashes immediately and I can't find any logs in my /tmp/ directory.

The second part of the issue is a specific .blend scene I'm working with. When I try to export the file using the native GLTF/GLB exporter on Blender 2.80 I am unable to see textures in online GLTF viewers (like https://gltf-viewer.donmccurdy.com/). If I export as seperate GLTF + textures + bin I see no textures folder.

Here are the files I am working with: https://send.firefox.com/download/3ca124498928be3c/#xYGd--ZDuHM0fq_x_lrCnw.

Appreciate any thoughts on this and whether I should report this as a bug.

$\endgroup$
2
  • $\begingroup$ For importing glTF, have you tried a newer copy of Blender than 2.80? For exporting textures, glTF supports a PBR-based material system, but not arbitrary texture hookups. See the Blender Manual for more detailed information on how to export materials to glTF. $\endgroup$ – emackey May 30 '20 at 20:19
  • $\begingroup$ I tried updating to the 2.82a version and it the import works perfectly now. Thanks! I am still a bit new to blender and the PBR-based material system. When I import my .blend scene there is no Principled BSDF node in the node diagram. Is there a way I can add it in? $\endgroup$ – screvival May 31 '20 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.