0
$\begingroup$

I'm new to blender and have been struggling having the bones only move the part of the mesh they're attached too while in Pose mode, and not having it duplicated on the mirrored side.

Normal Mesh and mesh when in Pose Mode

This is the only other question I found pertaining to the issue and its resolution did not work for me. Applying and mirror modifier, deleting half the mesh and recreating it.

Here are the current modifiers I have on the mesh. I have messed around with it to a decent extent, mirrored before armature, unchecking vertex groups, etc, but I wasn't getting any luck.

$\endgroup$
0
$\begingroup$

You need to have the mirror modifier first (on top) in you modifier stack, then the armature modifier.

In the mirror modifier have the Vertex Groups option enabled. This mirrors your vertex groups if they have _R / _L or simmilar endings. The bones on the left in your armature should have the ending _L and the bones on the right _R, so the vertex groups also get these endings.

If you create the armature, while in armature edit mode, you can switch on the X-Axis Mirror option in the tools panel. With this enabled, you can hold down shift while extruding from a middle bone to create two bones: one with the extension _L and mirrored version with the extension _R.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I duplicated the right hand side bones and then mirrored them to the other side with the cursor and name them all appropriately. As well as the vertex groups. !vertex_group However I am still getting the same effect !not functioning Do I have to recreate the armature from scratch since X-Axis mirror isn't available in the modifier section anymore? $\endgroup$ – J. Kohuth May 30 at 16:40
  • $\begingroup$ If all else fails, you can try applying your mirror modifier. I have found that it can sometimes solve this problem. I don't really know why anyone would want to keep a mirror modifier unapplied after all the modeling is finished anyway. $\endgroup$ – R-800 May 30 at 18:33
  • $\begingroup$ Don't manually mirror the vertex groups. That's what the "Vertex Groups" option in the Mirror Modifier is for. Just make sure you've got the ones that you want mirrored named with _L or _R or similar ending. $\endgroup$ – Simon Broggi Jun 9 at 15:18
0
$\begingroup$

So I applied the mirror modifier which let me select the faces on the left hand side. Using the vertex groups I'd select the faces of the _R vertex groups, deselect every right hand face then assign them to their _L counterpart. After that I would remove the _L from the default right counterpart

This was very time consuming and manual process but it got the job done

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.