1
$\begingroup$

I'm encountered similar problems a few times and can't figure it out. I have simple low poly mesh, normals are correct and there are no extra vertices but still some faces look darker.

Flat Shading

flat shading mode

Proof of no extra vertices https://gfycat.com/niftyshockedclingfish.gif

$\endgroup$
3
  • $\begingroup$ Merging faces by Distance with the default value only works, if the vertices share almost the exact same coordinate. It looks like you have copied vertices that are of by a tad more than that. Try Merge by Distance again, but change the distance value (bottom left corner) to a higher value $\endgroup$
    – Zagstrug
    May 30 '20 at 11:15
  • $\begingroup$ I did the same thing but there are no extra vertices. $\endgroup$ May 30 '20 at 11:22
  • $\begingroup$ Looks quite like a duplicate of this blender.stackexchange.com/questions/133816/… or linked one in there $\endgroup$
    – Mr Zak
    Apr 16 '21 at 19:15
1
$\begingroup$

This error is most probably caused by shade smooth. To fix this go to object data properties -> Normals -> Check the Auto Smooth Checkbox

enter image description here

$\endgroup$
0
$\begingroup$

Did you try to shade flat (Object mode, right-click or press W and there is an option)? And move the vertex. Maybe there is more than one.

$\endgroup$
3
  • $\begingroup$ There is no extra vertices I checked few times and the image I posted is already flat shaded. Also I tried smooth shaded too but nothing changed. $\endgroup$ May 30 '20 at 11:17
  • $\begingroup$ select those dark faces and press on f3 and search for flipped normals try that $\endgroup$
    – Kat Suvii
    May 30 '20 at 11:25
  • $\begingroup$ Nothing changed :( $\endgroup$ May 30 '20 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.