0
$\begingroup$

I am following this tutorial: https://www.youtube.com/watch?v=CwJrb3vjAaA He gets the waves on the ocean but I don't. I successfully made waves on a plane but not on the circle (see video). Basically I have to tile the plane onto the circle. I have attached screenshots. enter image description here enter image description here enter image description here

$\endgroup$
4
  • $\begingroup$ Can you say in the question what is the actual thing you are asking about? Thanks. $\endgroup$
    – user94339
    May 30 '20 at 1:03
  • $\begingroup$ @Patisawesome200 better? $\endgroup$
    – liaiwen
    May 30 '20 at 1:06
  • $\begingroup$ I don't see an edit on my side, but I will assume that you are asking about how to make the Ocean Modifier work on a circle. Is that correct? $\endgroup$
    – user94339
    May 30 '20 at 1:08
  • $\begingroup$ @Patisawesome200 no the video tells me to map bake of the ocean modifier from a plane onto the circle. $\endgroup$
    – liaiwen
    May 30 '20 at 16:02
1
$\begingroup$

The circle does not have enough geometry.

Displacement in Blender works by modifying existing geometry on the object. Your circle definitely does not have enough existing geometry to make displacement visible. This is an easy fix, just apply a subdivision surface modifier, or select all the edges and subdivide them in the edge context menu.

Additionally, I see that you are in Texture Preview mode. Note that displacement will only show as bump in that mode, and in order to actually displace the mesh you need to switch to rendered view mode in cycles and make sure that displacement and bump are both rendered.

$\endgroup$
5
  • $\begingroup$ ok, the video said to do 2 subsurf modifiers, and I did that, but it still isn't working. $\endgroup$
    – liaiwen
    May 30 '20 at 16:05
  • $\begingroup$ do I need to apply it? um I don't think I did that XD $\endgroup$
    – liaiwen
    May 30 '20 at 16:06
  • $\begingroup$ Yes, you do need to apply it. $\endgroup$
    – Eric Xue
    Jun 1 '20 at 19:32
  • $\begingroup$ I applied it and it still doesn't work :( $\endgroup$
    – liaiwen
    Jun 2 '20 at 21:56
  • $\begingroup$ @liaiwen did you go to Material->Settings->Surface->Displacement-> set it to "Displacement and Bump"? $\endgroup$
    – Eric Xue
    Jun 2 '20 at 22:04
0
$\begingroup$

apply the subdivision modifier and stick this displacement to bdsf normal section ... hope it's work

$\endgroup$
4
  • $\begingroup$ what are you talking about? $\endgroup$
    – liaiwen
    May 30 '20 at 16:05
  • $\begingroup$ The BDSF normal input will not actually displace your mesh but instead will shade the mesh as if it was displaced. You will need to connect it to the material output's displacement input in order to truly displace the mesh. $\endgroup$
    – Eric Xue
    Jun 1 '20 at 19:34
  • $\begingroup$ @EricXue How exactly do I do that? $\endgroup$
    – liaiwen
    Jun 2 '20 at 21:53
  • $\begingroup$ @EricXue I already have the vector displacment set to displacement $\endgroup$
    – liaiwen
    Jun 2 '20 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.