2
$\begingroup$

I have seen another post on this topic, but I couldn't find the solution. I'm following YouTube tutorials and added the image the same way they did but the image never shows up. When I switch the tab to texture paint mode I can see the picture, but with any other mode I can only see the yellow border of the image. Moreover when I started a fresh project and tried adding the image, it is working fine. Are any of my options disabled in my original project? Please help as I'm stuck and can't go further without solving this issue. I have made sure my image is jpg.

I have attached my image

Here's the .blend file

$\endgroup$
3
  • 1
    $\begingroup$ Would be great if you can share your blend file $\endgroup$ May 29, 2020 at 16:20
  • 1
    $\begingroup$ i have added my .blend file $\endgroup$
    – Vinurk
    May 29, 2020 at 16:32
  • $\begingroup$ I'm getting a 404 error when clicking your .blend file. Please use blend-exchange.com for sharing your .blend file. $\endgroup$
    – maddes8cht
    Oct 10, 2023 at 10:41

5 Answers 5

4
$\begingroup$

Show Overlays was turned off by accident:

enter image description here

$\endgroup$
1
2
$\begingroup$

Press Shift+S and then select Cursor to World Origin. I did it on your blend file and it worked.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ What!!! Im still not able to view the image. It only comes in the texture paint mode $\endgroup$
    – Vinurk
    May 29, 2020 at 16:43
0
$\begingroup$

Sometimes the name of the image file is the problem.

enter image description here

I had the filename named "Top" at first. I changed it to "Top_View" and the image showed up.

$\endgroup$
0
$\begingroup$

Image objects display requires that Overlays and its nested item Objects Extras both be turned on.

$\endgroup$
0
$\begingroup$

Just change your viewport shading to Material Preview and here it is, now your image will be visible

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .