I'm running the AssetSketcher v2.03 addon on Blender 2.82. Currently, it gives me an error when generating a preview image from a selected object: enter image description here

I checked in API Documentation and it seems there is alha_mode attribute in version 2.8 -hence the error - Any idea what I can change to make this work again?

Thank you in advance,


2 Answers 2


I just tried the link by the previous answerer: https://blenderartists.org/t/2-80-cheat-sheet-for-updating-add-ons/1148974.

It's said in it that:

So I just ran into this problem updating Level Builder, and the answer didn’t come up in a Google search so I am updating this necro thread. bpy.data.scenes[“Scene”].render.alpha_mode : [“SKY”, “TRANSPARENT”] is now bpy.data.scenes[“Scene”].render.film_transparent : [0, 1] Here’s hoping Google finds this answer for the next coder.

So I modified my code like this and it worked fine:

    if g_background_image_path == 'TRANSPARENT':
    # bpy.context.scene.render.alpha_mode = g_background_image_path # 2.79
    bpy.context.scene.render.image_settings.color_mode = 'RGBA' # blender 2.8
    bpy.context.scene.render.film_transparent = 1 # 0 for "SKY"; 1 for "TRANSPARENT

In the case of Python API you can try 1 or 2 .for general case try only 1

  1. Downgrade blender to blender==2.79 it would work


  1. You can update your script according to blender version >2.79



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .