0
$\begingroup$

Learning to model with Blender. Trying to modify an existing model, at some point I "wrinkled" it. I'm suspicious about some custom code (I'm developing a Blender plugin to export/import models from a game) to save and reload normals, but the case is I have this model now and I want to know what's going on so I can fix it.

With autosmooth turned off:

enter image description here

With autosmooth on:

enter image description here

What causes this? How can I fix it so when autosmooth is enabled, it looks like the figure on top?

$\endgroup$

1 Answer 1

1
$\begingroup$

Well, I found out that Reset Vectors in the Normals menu (Alt-N) seems to be the answer (you need to select all your vertices):

enter image description here

The result:

enter image description here

I don't know what I'm doing in my export/import code (that I mentioned above) but that's another story.

$\endgroup$
2
  • 1
    $\begingroup$ "Reset Vectors" puts normals back the to default calculation of the normals, which is the same as turning Auto Smooth off. Auto Smooth rarely makes sense on organic models. It's more of a feature for hard surface modelling,where you have rounded edges and plain faceted areas together in one mesh. $\endgroup$ May 29, 2020 at 2:36
  • $\begingroup$ I think the culprit in this case is that normals are messed up when the model is imported by my custom code, because this model (in its original state) works fine with Auto Smooth enabled. $\endgroup$ May 29, 2020 at 13:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .