0
$\begingroup$

T

I have been baking the Ocean Modifier result to textures. Using the EXR on a plane with a displace modifier clearly shows the texture doesn't match the Ocean.

Failing to find where I am going wrong here? It's set to not clamp and to RGB = XYZ

My goal was to use the Bake function to create Displacement, Normal and Foam to finally use them in Unreal Engine. But it seems it doesn't match. Left plane is using the texture; right plane is using the modifier.

Any help and pointers would be much appreciated.

$\endgroup$
2
  • $\begingroup$ Set the scale to 1 $\endgroup$
    – susu
    May 28, 2020 at 21:15
  • $\begingroup$ @susu Scales on both objects is 1; if you mean strength on displacement: Setting it to 1 makes the peaks curl over and also makes it even more obvious that the height map does not match - they look entirly different. $\endgroup$ May 29, 2020 at 8:32

1 Answer 1

1
$\begingroup$

Interchange the Green and Blue channel for each other. The Baked exr files are most likely done for the Vector Displacement node in Tangent Space mode inside the shader graph (Note: in the material Settings > Surface > Displacement set it from Bump only to Displacement only or Displacement and Bump). At least that is when it matches the geometry from the modifier on my end.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .