0
$\begingroup$

I have a question about rendering an animation.

For a research project I am trying to animate displacements on a steel frame. This steel frame has vertices and edges.

In my script I just updated the vertices' x coordinates and then keyframe it. The animation I get in object mode is really what I wanted to have but if I try to render this animation it doesn't work.

I think it is because of the non defined faces but is there a way to render a mesh which only has vertices and edges? (In object mode I can see the animation.)

(Note that this is not the whole script because the creation of the keyframes and the animation in object mode works.)

enter image description here

enter image description here

$\endgroup$
8
  • $\begingroup$ Hi. I don't think the animation or scripting part of the question is relevant as the issue seems to be about the rendering and nothing else. $\endgroup$ May 27 '20 at 15:09
  • $\begingroup$ Where can i find the Wire option in Version 2.82 ? $\endgroup$
    – Philipp
    May 27 '20 at 15:23
  • 1
    $\begingroup$ If the viewport is good enough, you can disable everything in the overlay but the edges (click on the arrow on the right of the two intersecting discs on the top right corner of the viewport, and uncheck everything), and render your animation directly with "View > "Viewport Render Animation". $\endgroup$
    – Gorgious
    May 27 '20 at 15:24
  • 1
    $\begingroup$ @Gorgious If you have another answer, add it over on the duplicate question :) $\endgroup$ May 27 '20 at 15:26
  • 1
    $\begingroup$ @RayMairlot Will do a bit later when I have more time :) $\endgroup$
    – Gorgious
    May 27 '20 at 15:27

Browse other questions tagged or ask your own question.