3
$\begingroup$

I have issue with inset feature, works fine on regular shapes, but when the faces has odd shapes, there is a lot of faces overlapping.

I have read that there is an option that allows to auto merge vertices while inseting, but i can't find the option. Can someone help me with this?

$\endgroup$
1
  • $\begingroup$ I'm trying to envision a scenario where this function would be of use. As I see it, while insetting, you don't want vertices to even collide with existing ones that might exist on the initial plane, let alone merge with them. Would you be willing to go into more detail about what you are actually trying to do? There may be another way. $\endgroup$ – R-800 May 27 '20 at 14:39
4
$\begingroup$

This is possible using the Straight Skeleton Inset function.
It's basically a 'smarter' inset tool.

  1. Enable it in Preferences > Addons > Inset Straight Skeleton
  2. Select your faces and go Face > Inset Straight Skeleton
  3. Done.

You can see the vertices are merging, instead of overlapping.

enter image description here

$\endgroup$
4
  • $\begingroup$ Exactly what i was looking for! thanks! $\endgroup$ – Eric Brochu May 27 '20 at 21:56
  • 1
    $\begingroup$ Happy to help, good luck with your project :). $\endgroup$ – Jachym Michal May 27 '20 at 22:16
  • $\begingroup$ @RobinBetts Glad you find it useful. It's odd such a tool is hidden by default :). $\endgroup$ – Jachym Michal Aug 17 '20 at 9:05
  • 1
    $\begingroup$ Could be a standard option of the Inset tool $\endgroup$ – Robin Betts Aug 17 '20 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.