2
$\begingroup$

Everything shows up in render. (using blender 2.70a)

Render

But in 3d view only the mesh shows, switching between wireframe & solid only shows wireframe (or the option we get to change with "Z" key)

with wireframe viewport toggled with wireframe

with solid viewport toggled with solid

Only changing "maximum draw type" to solid or textured shows white shading but not the orange color I gave in materials.

enter image description here

New cubes show shading though.

$\endgroup$
  • $\begingroup$ What is the question? I'm not sure I understand.. Changing the maximum draw type to textured and switching to textured view should work $\endgroup$ – gandalf3 Oct 20 '14 at 20:52
  • $\begingroup$ blenderLearner. I think you should edit out the two wireframe pictures in the middle. They don't help to make your point and are misleading because they are irrelevant to your point but seem to have some point just because they are there. $\endgroup$ – MarcClintDion Oct 20 '14 at 22:59
  • $\begingroup$ @MarcClintDion I think that is the point.. Or it might be, currently it's kindof vague.. $\endgroup$ – gandalf3 Oct 21 '14 at 0:36
  • $\begingroup$ New to English or new to the world I suppose. Anyways, I like Stackers answer, I never use that mode and totally forgot about it. $\endgroup$ – MarcClintDion Oct 21 '14 at 0:50
  • $\begingroup$ The point of the 2 mid images is that the viewport is toggled to be in wireframe & solid respectively, but blender only shows the wireframe. And the last image give me a solid view but I don't see the orange color given. $\endgroup$ – blenderLearner Oct 21 '14 at 4:26
3
$\begingroup$

I guess you expected the solid or textured mode not to be rendered partially transparent, This is because you're in Edit Mode and have toggled the Limit selection to visible option:

enter image description here

$\endgroup$
  • $\begingroup$ This helped with transparency but I still can't get to see the orange color I have given to it. $\endgroup$ – blenderLearner Oct 21 '14 at 4:31
  • $\begingroup$ @blenderLearner could you upload your .blend at pasteall.org/blend ? $\endgroup$ – stacker Oct 22 '14 at 15:37
  • $\begingroup$ Actually I started again from scratch and saved over the old file. Your answer did solve that transparency. $\endgroup$ – blenderLearner Oct 23 '14 at 15:31
2
$\begingroup$

Aside from the several other wonderful answers given. You can also change the viewport color at the bottom of the materials panel of the properties editor. This does not in any way affect the rendering of the object it will only color the object in solid view mode.

$\endgroup$
1
$\begingroup$

By default the Maximum draw type is set to textured.
This is a per object setting, so new objects will have this set to textured.

This setting defines the maximum draw type of the object, in the order of

  1. Bounds. Draws the object's bounding box.

    With maximum draw type set to bounds, the object will only ever be drawn as a bounding box.

  2. Wire. Draws the object's edges as a wireframe.

    With maximum draw type set to wireframe, the object will only ever be drawn as a bounding box or a wireframe.

  3. Solid. Draws the object's faces as a surface.

    With maximum draw type set to bounds, the object will only ever be drawn as a bounding box, wireframe, or a solid surface.

  4. Textured. No limit.

    With maximum draw type set to Textured, the object is allowed to be drawn in the viewoprt with shading, textures, etc.

Most of the time you want it on textured, but it's sometimes useful to e.g. keep a specific object drawn as a wireframe even while in solid view.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.