3
$\begingroup$

I'm trying to make a test render of my model. But everytime I render it the render looks completely different from the viewport. The viewport is in render mode so it should look something like that, but this doesn't come even close.

I'm using cycles renderer. And my world note is just the standard one so nothing installed there. There are 2 sun's in the scene both set to 0.5. I've tried different hdris but they all have the exact same outcome. I've pressed alt+h to see if there was anything hiddden in my scene that blocked the background and nothing shows up so I don't think that's the problem. I've also copied it to a new Blend file to see if there was anything wrong with the file itself but it also happens there so it must be something in my settings I guess. But I just can't find out which one

enter image description here

this is how it looks in the viewport render.

enter image description here

And this is how it looks when I render it.

I really don't know how to fix this so I hope someone can help me here

$\endgroup$
3
$\begingroup$

It looks different in the preview because in Material Preview Shading there is an HDRI already set up for convenience, but that HDRI is not used for Render Shading.

enter image description here

How to use an HDR image as environment.

In the world section, set the surface to Background, assign an Environment Texture to the color slot and then select any HDRI image you want to use:

enter image description here

Enable Scene Lights and Scene World to override the viewport settings:

enter image description here Gif from: How can I render an object with an hdr background?


Related

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.