0
$\begingroup$

I'm trying to work out a problem that's best described visually: the problem.

I'm trying to snap a vertex to where its y-axis contraint intersects the face of another object, which apparently doesn't work the way you think it would. Instead of snapping to that one possible point, the vertex just goes as far as the y-coordinate that the mouse points to on the face, while the vertex is still on the axis constraint.

Is there an official way to do this? If not, what is a good workaround or plugin to achieve this? I don't want to eyeball it, I want to do it precisely.

If not, is there a place where I can request this feature to the Blender developers? It seems people have been asking this question on different websites since 2013, yet it seems the developers haven't been informed about this at all. There never really was a helpful answer, and I was hoping that there'd be an update of sorts by now (with the coming of Blender 2.83), hence me asking this again.

$\endgroup$
  • $\begingroup$ it works fine here with Blender 2.79 and 2.80, so there might be some debug to do on the latest version? $\endgroup$ – moonboots May 25 at 17:37
  • $\begingroup$ @moonboots Just downloaded 2.79, still not working. But if you know for sure that this particular scenario really does work for you in 2.79, maybe the problem is not my Blender version but my settings (since it's still not working for me). Which related settings do you think could be different for you? $\endgroup$ – INEEDANSWERS May 25 at 17:57
1
$\begingroup$

I can't get snap-to-face to work the way I would expect in 2.83beta, either..

The shipped TinyCAD add-on is one option, for this one..

  • Activate TinyCAD
  • (Assuming source and target are part of the same object) Select 1 face, 1 edge
  • Use TinyCad's Extend Edge to Face
  • (Maybe with Automerge switched on) GG slide the source vertex down the extended edge, all the way, onto the projected vertex.

I agree, the snap system could be improved.. important to keep it quick and minimal, though, IMO.. hunting through the snap options in some apps is not fun.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thanks, this does come close, but this only works: (1) in case the edge the edge that leads up to the vertex is parallel to the world axis(/constraint), and (2) if you're trying to put a vertex on a face. This wouldn't work if I was trying to get an edge/face on the face like so. $\endgroup$ – INEEDANSWERS May 25 at 18:57
  • $\begingroup$ Yup... I see... $\endgroup$ – Robin Betts May 25 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.