2
$\begingroup$

I import a model from binary data and figure out that its normal vectors are in wrong direction. After flipping vectors, the faces do not look smooth like before although I try to use "Shading/Smooth faces" and "Clear sharps" feature. How could I do to make the face look smooth in this case? I attached the .blend file here. Thanks. Download sample

Before flipping normals Before flipping normals

After flipping normals enter image description here

$\endgroup$
3
$\begingroup$

Your mesh has 211 double vertices that mess up the shading.

Select all vertices (Ctrl+A), disable Autosmooth and go:

  1. Mesh > Clean up > Merge by distance (this will merge 211 double vertices)
  2. Mesh > Normals > Recalculate outside
  3. RMB > Shade Smooth

This will ensure you have a clean mesh, normals pointing out and proper shading.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.