0
$\begingroup$

I recently asked this related question about animating a solid mesh into smoke, and a solution that I might use is to shroud the mesh in smoke heavily whilst the mesh animates to zero opacity, which sounded simple, except there's a problem:

The mesh owns the smoke, and mixing it's material with a transparent shader hides both the mesh and the smoke.

How can I hide the mesh without hiding the smoke also?


One solution that I thought of could be to create a duplicate of the mesh to contain the smoke that is set not to show the smoke emitter, and then as I hide the mesh that is shown, the emitter will remain but the smoke will continue. This would work, but it's a work-around (noob-ish) way to handle it.

$\endgroup$
3
  • $\begingroup$ you can try using different layers for the object and the smoke. Then recombine the layers in the compositor. At that point you can manipulate the degree of transparency, or even use masks for more sophisticated control. $\endgroup$ – user1853 Oct 20 '14 at 0:44
  • $\begingroup$ Are you using BI or cycles? $\endgroup$ – gandalf3 Oct 20 '14 at 19:19
  • $\begingroup$ @gandalf3 Cycles. Sorry $\endgroup$ – J.Todd Oct 20 '14 at 19:22
2
$\begingroup$

If I understand the question correctly... I think you are on the right track. Simply disable the render-ability of the emitter object like so:

enter image description here

Then duplicate the emitter object and apply to it the shader which animates from opaque to transparent. (As described in this thread -> How can I animate an opaque material to being fully transparent in Cycles?)

$\endgroup$
1
  • $\begingroup$ The question cited = also mine ^_^ $\endgroup$ – J.Todd Oct 20 '14 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.