0
$\begingroup$

new to Blender here and I'm trying to make an object of a specific size that I can 3D print. Here's what I'm doing:

  1. File> New> General, select the cube and delete it.
  2. Go to the Scene Properties tab and under Units, make sure the system is Metric and length is in mm.
  3. Add mesh> Cylinder
  4. In the Add Cylinder box that pops up, change the vertices to 64, radius 20mm, depth 4mm.

This creates an appropriate cylinder, but it's really tiny in the window and I have to scroll in a lot to see it. Once scrolled in, I have about 3 clicks of my scroll wheel before it goes from barely visible, to visible, to now we're inside it. Working with such a small object has been really difficult.

When I export the object as a .stl and open it in Chitubox, the cylinder is so small that it isn't visible. If I click to resize it, Chitubox tells me that the object is 0.04mm(x) by 0.04mm(y) by 0.00mm(z).

What am I doing wrong here?

$\endgroup$
  • $\begingroup$ Hi, welcome! You surely need to adjust view clip to 1mm (open options panel Nkey, and then switch to the side "view" vertical menu of th epanel), the tiny object displays well with that. Dimensions are expected ones, and I tried exporting and then importing as stl, it seems dimension are right for blender... $\endgroup$ – m.ardito May 24 at 18:48
  • $\begingroup$ So I press the N key, click the View tab, and then what? $\endgroup$ – Wild_Alaskan May 24 at 18:59
  • $\begingroup$ then you set the "clip start" to 1 mm, in this way you should be able to see entirely your object even at that tiny size $\endgroup$ – m.ardito May 24 at 19:07
  • $\begingroup$ This made no change for me. $\endgroup$ – Wild_Alaskan May 24 at 19:18
  • $\begingroup$ Did you try to create the object say 1000x then in the slicer, scale it down 1000x? It could work as a workaround. What you hit is probably a bug in the stl exporter. I only tried on viewstl.com though $\endgroup$ – m.ardito May 24 at 19:33
0
$\begingroup$

I had the exact same problem.

enter image description here

First, make sure your scale on the object is 1:1.

I Highly (x10!) recommend you abandon all thoughts of using English/Imperial units and go to millimeters.

In Properties Panel, Scene, Units, set Metric Unit to 1.000. Length=Milimeters

The second image is the key that will open the city. That little "Scene Unit" checkbox (Always check to make sure this is ON!).

Me? I save these settings as a default startup file so I have these settings are correct to begin with.

Oh! On the second figure... don't forget to also inspect the "Include, Selection Only checkbox"!

I use the Measure-It tool (to aid in displaying key dimensions 'say' overall height and width for example.

I personally export to Stl files. On the 3D printer side of things, I recommend Simplify 3D . It's good investment. I forget the $ but it isn't much. Stay clear of nylon filament (strong but doesn't stick to the build plate) but choose Raptor and other "Print in place" type filaments. Raptor is stronger than ABS. PLA is weak but good for practice runs.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ I've double checked and done everything you suggested; it has made no difference. $\endgroup$ – Wild_Alaskan May 24 at 19:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.