1
$\begingroup$

EDIT: Since I posted this question, I tried re-downloading the original model and rig, and when I tried to export it to fbx it works just fine. Gltf still shows the error message. In adding materials and my own animations, something I had done must have caused the exporting process to go wrong, although I don't understand what it could have been.

I have a rigged, animated mesh that I cannot export to .gltf without getting an error. If I use dae or fbx the model will export, but importing it into another program (Godot or back into Blender) shows the mesh stretched out in all directions. All other blend projects seem to work just fine.

This is the link to where I got the rigged model: https://drive.google.com/file/d/1FIDhinZ-57lKd-unAekoidz3Un-6ZFMT/view

The first error I receive from gltf in the error report is:

File "C:\Program Files\Blender Foundation\Blender 2.82\2.82\scripts\addons\io_scene_gltf2\blender\exp\gltf2_blender_gather_drivers.py", line 53, in get_sk_drivers sk_name = child.data.shape_keys.path_resolve(get_target_object_path(sk_c.data _path)).name

There are about 20 other errors that come after this one, all in the same gltf2 exporter addon file. I can post more if that would be helpful.

Here's a picture of reimport from FBXenter image description here

and from DAE

enter image description here

I'm trying to get the model into Godot (3.2), if anyone knows an easier way to do that. The meshes have the same stretch effect in Godot as well.

$\endgroup$
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.