2
$\begingroup$

I have some subdivision + UV boundary problem My English is poor. So I prepare image enter image description here

As you see the picture The Blender's result of UV islands boundaries are different with other DCC, after subdivision I think my blender "smooth, keep corners" option didn't work properly I need the same Result, Like Maya and 3Ds Max

I use blender for modeling and Texture painting But I cannot do texture paint with This kind of UV islands boundary result to export to other DCC Please!! Help me!!

Thanks!!

$\endgroup$
2
$\begingroup$

to get the same result as Maya/3DS Max, follow these steps:

  1. apply SubSurf modifier with Sharp option instead of Smooth, keep corners

    first-step

  2. your uv layout will be changed into this (notice the sharp borders)

    second-step

  3. select uv's borders and pin them (press P key), so those vertices will keep the position in the uv-space (pinned vertices are red)

    third-step

  4. select all vertices (in the uv editor) and press U to update all the other vertices - you should get this result

    fourth-step

| improve this answer | |
$\endgroup$
  • $\begingroup$ Oh, so this is how you use the sharp option :). Thanks. $\endgroup$ – Jachym Michal May 24 at 10:42
  • $\begingroup$ Thanks for your solution!! Usally I painted Low-polyon with Ctrl+1 or Ctrl+2 subdivision surface As you know, Painted with Ctrl+2 and then turn the model Ctrl+0 There are problems with UV islands boundary opposite way, Painted with Ctrl+0 and then turn the model Ctrl+2 There are also problems with UV islands boundary I think I need more radical(?) solution So kind of Subdivision Add-on or Blender subdivision option But. this is really cool solution. Thanks sir!! $\endgroup$ – Seung-hee Choi May 24 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.