1
$\begingroup$

I used animations from Mixamo for a game project, a humanoid character (ybot). I used an add-on called Godot Game Tools to combine different animations and duplicate them. I duplicated the animations and modified the rotations of spine bone and replaced the key frames. When I opened the project later the animation had some unwanted transforms in it. The character is shifted slightly to up.

Screenshots: screenshot

When I was modifying this animation there was no such problems, when I changed the animation to something else and back the problem occurred. Every animation I made this way has problems like this. I did it yesterday and I noticed this today when I opened my Blender project.

As a workaround for now I opened each animation and changed the transform of the hip bone individually. I have to again modify many animations to correct this.

Is this a bug ? What causes this problem and why ? How can I fix it ?

Please help!

Edit: Here's the blend file

$\endgroup$
10
  • 1
    $\begingroup$ Please share blend with before and after armature via blend-exchange.giantcowfilms.com $\endgroup$
    – vklidu
    Commented May 23, 2020 at 13:15
  • $\begingroup$ I think the problem is when I key frame, the root bone (Hip) changes its position. I'll try to provide a blend file. $\endgroup$
    – Icosagon
    Commented May 24, 2020 at 4:41
  • $\begingroup$ When I created a new project and did this, this glitch is not seen, It maybe my fault :D. Should I delete the question ?. Sorry for the trouble. $\endgroup$
    – Icosagon
    Commented May 24, 2020 at 4:50
  • $\begingroup$ if you provide more info to your question, so you or others will be able to answer it, you can keep it. (Also others can get into the same issue.) But ... like now, it would be better to delete it. Thank you $\endgroup$
    – vklidu
    Commented May 24, 2020 at 7:24
  • $\begingroup$ I thought I solved this problem and again it reappeared, I have provided the blend file. The original file had many files and it was 100 MB, I deleted most of the animations to reduce the file size. Please help $\endgroup$
    – Icosagon
    Commented May 24, 2020 at 10:11

1 Answer 1

0
$\begingroup$

You use Replace blending mode for these strips, but I would say you probably used Add when you edited action. Changing back to "Add" blend type - seems solved the issue here.

enter image description here

There of course matter what blend mode you used while editing, also there matters what action is used bellow.


BTW

To do changes on imported animations I would use NLA editor to adjust animation. If you use GGT add-on its automatically imported as NLA action strips (animations).

I cleaned up all unused tracks and left only one to keep it more clear. ("Riffle_Crouch_Walk")

enter image description here enter image description here

Action editor
- create a new action
(or delete existing and add keyframe for selected bones in Pose mode) - here you can do all edits that are Replaced, Added or what ever (is set in NLA strip properties) on top of imported track (action)

NLA editor
- top action is always used (if not disabled) - top row (with dope sheet icon) is always editable one - all bellow (with star icon) are "Push Down" for strip mixing (like now "Riffle_Crouch_Walk" imported action)

When you finish edits, you can search "Bake Action" (with cursor inside NLA editor) into one animation.

See blend file

$\endgroup$
3
  • $\begingroup$ Thank you for helping, but any idea why the root bone (hip) got displaced in the animations aim down and up animations ?. $\endgroup$
    – Icosagon
    Commented May 26, 2020 at 12:36
  • $\begingroup$ @Icosagon: OK, it seems to me I got it, check beginning of the answer. $\endgroup$
    – vklidu
    Commented May 26, 2020 at 21:52
  • $\begingroup$ Thanks for helping $\endgroup$
    – Icosagon
    Commented May 27, 2020 at 3:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .