0
$\begingroup$

This is a bit of a mixed question as I'm using both Blender and Substance Painter. I am hoping that someone with a Blender > Substance workflow knows what's causing my frustration.


I am following this tutorial.

Here is my blender file: tracer_redo_final_bake_3.blend

Here is my low poly mesh: tracer_low.fbx

Here is my high poly mesh: tracer_high.fbx


Here are both meshes as they appear in blender for convenience:

High Poly Gun:


High Poly Gun

Low Poly Gun:


Low Poly Gun

When I try to bake the normal map in Substance, the details come out completely wrong and there are a lot of artifacts. I am aware that some artifacts are normal and I'm not striving for perfection here, but I'm not getting any of the beveled edges or further detail after the bake. The edges that are supposed to look beveled end up sharp and the model gets really splotchy. This doesn't occur in the tutorial video.

Here's a screenshot:


Broken Bake

Here are the settings in Substance that I'm using for the bake:


Substance Bake Settings

I know that I can bake normals inside of Blender, but I really want to figure out how to do it correctly in substance painter for workflow reasons.

Is there any possibility someone could look at my files and tell me what I'm doing incorrectly? Could this be a blender-specific problem? This is my first attempt at baking and texturing something remotely complex, so I'm kind of overwhelmed.

A huge thanks for any assistance at all!

$\endgroup$
  • $\begingroup$ This doesn't feel like a Blender question, but: Do you have consistent normals, and is your main (uppermost in the list) UV map overlapping? $\endgroup$ – Frederik Steinmetz May 23 at 10:39
  • $\begingroup$ There is no substance painter/designer SX and since Blender > Substance is a pretty common workflow I figured I would ask this here. Sorry if it's a bit offtopic! $\endgroup$ – Cultmethod May 23 at 20:40
0
$\begingroup$

I figured out that by selecting "Relative to Bounding Box" in Substance fixed the issue for me. I am kind of mystified why this worked, but it did. If anyone knows why this happens it would be a great help.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.