0
$\begingroup$

I have 2 images (as planes) and a particle emmitter in between. When previewing, no particle come through the image as in this screenshot: Link

When rendering the video, the particles do come through the image (as plane), like this: Link to second screenshot. Why is this happening? I have "Collision" physics with "Kill particles" checked for every mesh and node.

Here is another screenshot which describes this pretty good: enter image description here

$\endgroup$
0
+100
$\begingroup$

I can confirm that the collision system (die on hit) is not 100% accurate or at least is not calculated when two meshes touch (it could be also because of settings from the "integration" panel under physics - like integration type, Timestep or Subframes).

The solution I can suggest is to create a duplicate version of your collision mesh and move it a little closer to the emission object. Set this duplicate as collision and hide it from the render.

It will act as emitter killer, but it won't be rendered.

The distance from the original object should be something around the RADIUS of the object you are using as source (calculated also with in mind the Scale of Render simulation).

Check this image:

enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ I actually achieved a similar solution, I placed an invisible cube under the plane which kills the particles a bit earlier, which works too. I thought there were settings or blender is able to precisely calculate such collisions, but it seems the particles go through the plane. Might be something with the plane only, I don't know $\endgroup$ – Кристиян Кацаров May 24 '20 at 18:28
  • $\begingroup$ I have played with the timestep by the way, to increase the step, maybe I did it wrong? $\endgroup$ – Кристиян Кацаров May 24 '20 at 18:29
  • $\begingroup$ Just one last question.. how do you hide it from rendering, like using a special shader or? Am still learning blender, sorry if this question is too.. novice :) $\endgroup$ – Кристиян Кацаров May 24 '20 at 21:06
  • $\begingroup$ check this: i.imgur.com/rTjEHrC.gif $\endgroup$ – Sanbaldo May 24 '20 at 21:25
  • $\begingroup$ Nice one, thank you. The interface is pretty frustrating for beginners $\endgroup$ – Кристиян Кацаров May 24 '20 at 21:55
0
$\begingroup$

There are a few things that you might check / do - Make sure the particle system doesnt render dead particles - Under physics integration you might increase Subframes (default 0), to simulate sub frame positions for better accuracy - Bake the emulation to a Disk cache (making sure you dont depend on slightly random differences in math results - on collision phyiscs make sure prmeability = 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.