0
$\begingroup$

I have been going at this for hours searching every possible combination of keywords through Google, and nothing.

I made a model, rigged/weighted it, and put someone's dance animation on it... which works fine in the Viewport, exactly how I want it, and even Image Rendering works fine at whichever frame I'm currently on.

But now, I want to render a short clip of the animation (just between frame 2424-2500 as a test) into a video file. The output seems fine, it renders and looks fine except that there is no armature animation for the body, BUT the face's shape key animations (blinking, talking, etc) works just fine, which are also on keyframe animation... And even the hair and ears jiggle as they should, and the camera is fine (even tried an animated camera and the camera will animate fine!). But only the actual body will not animate like it does in the Viewport, because once I render the animation, it will just show the character standing still with only face and hair jiggle animation, no actual bone movement. So what gives?

I don't think the engine makes a difference, but I am using Eevee because my shaders require it. I have a feeling it could be something in the Animation window or even the armature rig itself (I originally made it in an older Blender 2.76 or 2.79)? But I cannot figure it out. I've been at it all day, since this morning, and it's already 9pm and I have not figured it out.

This is what the "Render Animation" gives me, after it has gone through every frame on the timeline that I set, it still gives just this, where you can see the hair and face animated fine, but no bone movement because he should be moving around: https://photos.app.goo.gl/AL3WMfiYBq1B6xK77

This is what it looks like playing on the Viewport, which is how it SHOULD look like (but smoother lines, which is why I want it to render): https://gyazo.com/b3a1e74a798ecee49edfd0ab5088af00

And this is my .Blend file, if anyone wants to try and see what could be wrong if there's anything with my file messing it up: https://drive.google.com/open?id=1RlRiYvQR-7S-7_4m7CnGErS-m5xrsgk3

$\endgroup$
1
$\begingroup$

It worked for me straight away in Blender 2.82a

My suggestion is to use that version. Anyway I might have had a similar issue in the past. If I remember correctly I moved the frames to the start (e.g. 0-76) and that fixed the problem. Hope it helps

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for the suggestion. I will try this now. PS: Oh wait... actually I am using 2.82... but I can try repairing it... Either way, if it works for you, then there is something on my end it seems. $\endgroup$ – Angela Kimiko Yee May 22 at 18:14
  • $\begingroup$ Well, it's been 9 days and still nothing. :( $\endgroup$ – Angela Kimiko Yee May 31 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.