0
$\begingroup$

So for context I'm following along with a tutorial and the course lecturer demonstrates a usage of Blender Edit mode with X-ray enabled (set to 1.0) that shows semi-transparency for faces. Useful for selecting vertices on either side of an object for efficiency reasons (x ray mode) It's how it worked in Blender 2.79(?), but has been changed since. I believe the more important usage is that you can have per object transparency in a scene with multiple objects in it without making the entire scene transparent in Object Mode due to x-ray being enabled.

Here is an example of the intended effect from my friend:

enter image description here

As you can see, you get semi transparency in Edit mode with x-ray enabled, without having the faces completely transparent like you might in Wireframe.

After some troubleshooting and also having 3 separate friends test this in 2.82, 2.80 and producing the same result as the lecturer, I decided to try it in 2.82 (not 2.82a, which is what I was previously using) myself. I am avoiding downgrading to 2.80 if possible because I want to be able to use the overhauled sculpting tools.

I still am unable to get the intended effect of being able to view the selected object as transparent in edit mode and solid in object mode. Both mode's show the object as 100% solid.

enter image description here

enter image description here

Some things I did notice are that my wireframe's default x-ray setting is set to 0.5, my understanding is that it should be set to 0 by default. Not sure why this happens..so I change it down to 0 and I noticed that  I can produce the intended effect of semi-transparent faces if I reduce X-ray down to 0 in Wireframe mode (which isn't what you're demonstrating), but this only lasts between a few changes between Solid>Wireframe>Solid, and eventually Wireframe mode shows no semi-transparency for the faces.

You can see that affect here : enter image description here

I also tried to reduce my x-ray to 0.999 and received these results :

enter image description here

This seems to create sort of transparent faces, but you can see that the edges are almost like dotted lines and the vertices are not visible.

This is really puzzling and at this point feels like a system specific issue for me. This is a nearly fresh install of Windows with new drivers and I've gone as far as reinstalling Blender both through the website, and even Steam as well (with restarts in between) so I'm not sure how I can even troubleshoot or fix this. Though this functionality is definitely not necessary nor required, I am concerned that the fact that it doesn't work as it should may cause me to run into more issues (or not realize im running into them at all!) later on so I'm trying to see if anyone could determine whats going on here.

Hopefully my explanation here is thorough enough that my issues are clear. Sorry for the inconsistency between the screenshots, I had completely reset my user preferences after awhile as to verify whether or not that could be affecting it.

$\endgroup$
1
$\begingroup$

when your x-ray is set to 1.0 it means that the visibility of the object is set to full. 0,5 means that the visibility is on half and 0 means that the object is completely see-through (invisible). When your shading mode is set to wireframe, wires will be visible no matter how low the visibility is set. The visibility you want is set by default.

Visibility set to 0.5, shading - solid mode, object mode Visibility set to 0.5, shading - solid mode, object mode

Visibility set to 0.5, shading - solid mode, edit mode Visibility set to 0.5, shading - solid mode, edit mode

| improve this answer | |
$\endgroup$
  • $\begingroup$ I understand this, the method given in the lecture is Visibility set to 1.0, full visibility in Object Mode and half visibility(?) in Edit Mode. Basically allowing you to have x-ray mode enabled all the time without making everything transparent, but only getting transparency per object when selected in edit mode. $\endgroup$ – meanie May 19 at 19:34
0
$\begingroup$

So it seems after doing a full factory default reset and using the default theme it functions properly.

I've re-installed the Dracula theme I was using by putting the xml directly into the Blender theme folder and it seems to work properly that way as well.

No idea what the issue was but it seems to work now.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.